Neler yeni
Blue
Red
Green
Orange
Voilet
Slate
Dark

Eğitim Flutter Hatası Ve Çözümü

Omer

Üye
.
Katılım
17 Eyl 2021
Mesajlar
6
Tepkime puanı
2
Puanları
1
Konum
Bahçelievler İstanbul
Hata:

[firebase] flutter pub get
Running "flutter pub get" in firebase...
Because cloud_firestore >=0.13.4 <0.14.0-dev.1 depends on cloud_firestore_web 0.1.1 which depends on firebase 7.0.0, cloud_firestore >=0.13.4 <0.14.0-dev.1 requires firebase 7.0.0.

So, because firebase depends on cloud_firestore 0.13.7 and firebase is 1.0.0+1, version solving failed.
pub get failed (1; So, because firebase depends on cloud_firestore 0.13.7 and firebase is 1.0.0+1, version solving failed.)
exit code 1


Çözüm:

Kütüphane versiyonlarında hata alıyorsun. Öncelikle flutter 1 mi 2 mi kullanıyorsun bilmiyorum. Fakat pub.dev den cupertino_icons hariç tek tek yazmak ve son sürümleriyle değiştirmek hatanı çözecektir. Örneğin firebase_storage 10.0.3
çıkmış fakat sen o kütüphanenin çok eski bir sürümünü indirmeye çalıştığın için hata alıyorsun. https://pub.dev/packages/firebase_storage
 
Üst Alt